When record is Saved - triggering on Record open

  • 0
  • 1
  • Question
  • Updated 1 year ago
  • Answered
I have a simple Form Rule that says:
When the record is saved (after checking), if Field A does not equal 100% then Abort the Save.
My problem is that it seems to be triggering as soon as the Form is opened.  The default for FieldA is null and I want it that way so the user has to consciously make an entry, but I don't want them to Open the form and be greeted by an error message before anything else.
Am I doing something wrong here?  Is this a known bug?
Photo of Richard Pfister

Richard Pfister

  • 554 Points 500 badge 2x thumb
  • confused

Posted 1 year ago

  • 0
  • 1
Photo of Matthew Neil

Matthew Neil

  • 31,478 Points 20k badge 2x thumb
Can you share a screen shot of the rule?  and any other details or other rules that may be interfering with this?
Photo of Richard Pfister

Richard Pfister

  • 554 Points 500 badge 2x thumb
I disabled all the other rules so I feel like they shouldn't have any impact.  The fact that there is ??? in my Rule makes me think I'm not entering a parameter, but I don't see where to enter it.
Photo of Matthew Neil

Matthew Neil

  • 31,478 Points 20k badge 2x thumb
Sorry for the delay.

Percent fields are actually 1 displayed as 100%.  
Try changing your rule to be not equal to 1
Photo of Richard Pfister

Richard Pfister

  • 554 Points 500 badge 2x thumb
Thanks for the response Matthew.  I don't know how to close this question but either it was temporary behavior or I changed something that incidentally made it a non-issue.  It doesn't trigger when the record is opened anymore but my other thread about it only triggering once on Save is still an open concern.  Thanks for your help.