Why am I not getting a dropdown for a Formula List-User field as an Initial Filter when instead just shows a freeform field?

  • 0
  • 1
  • Question
  • Updated 4 years ago
  • Answered
I'm creating a report where I want to show the "current user" all of the different records that somewhere includes their name.  I'm stumped on why this is happening, but for one field I'm trying to filter on in particular, I get just a free form field instead of a drop down (see the attached screenshot).  A couple of other fields, that are List - User types, are giving me the dropdown so I can select "<the current user>", but the "Product Owner(s) of this Commitment" field (circled in red in the screenshot) is just a free form and entering the text "<the current user>" or "User()" will not work.  Any thoughts on how to fix this or change my logic?  The circled field is a Formula - List - User type, so perhaps that has something to do with it, but I'm not sure why that matters.

Photo of Paul

Paul

  • 0 Points

Posted 4 years ago

  • 0
  • 1
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 65,320 Points 50k badge 2x thumb
There are two choices to get around this.



1. Create a formula-User called [Current User] with a formula of


User()

Then make your filter where[Product owner(s) of this commitment includes the user in the field [Current user].


2. You can also make the condition to _curuser_  ( you need to have the leading and training underscores). That is the magic string which means the current user in a filter.