Why is my newly created table report not showing on the drop down list of reports to use to base my Report Link field on?

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
See my screenshot to understand what I am referring to. For reference this is in regards to the form properties of my Timesheets table and the Report Link field I have within it.

You can see that there are 11 reports on the drop down list under where it says "Base the display on the report:" And from the names of the reports you can likely tell that I am in my TimeSheet Table. I made a new table report in the Timesheet table but for some reason it does show on the drop down list. What on earth am I doing wrong? I even made it identical in every way to one of the 11 reports just as a test and it still does not show. I then made another new report and that one does not show either. I can't figure it out.  Help!
Photo of Robin CC

Robin CC

  • 200 Points 100 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 65,096 Points 50k badge 2x thumb
... and change that was just a personal report that you made.
Photo of Robin CC

Robin CC

  • 200 Points 100 badge 2x thumb
No it is a common report.  Can be viewed by all.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 65,096 Points 50k badge 2x thumb
So just to be sure that there is no confusion as to which table actually has the report, when you go to settings for the table with those reports, is your report there?  And if so, are all the other reports that you see in that drop down there too in the master list of reports?  ie does that master report list have all the reports in that dropdown plus one extra that the drop down on the form does not show.
Photo of Robin CC

Robin CC

  • 200 Points 100 badge 2x thumb
Yup.  The master list of reports in table settings shows all 13 reports.  That's the original eleven which show on the form drop down plus the two I made yesterday.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 65,096 Points 50k badge 2x thumb
Well, I have no idea.  Maybe make a new report, or is that why you already have 2 extra?  Any chance the new report has an <ask the user> filter and as such is an illegal report to use?
Photo of Robin CC

Robin CC

  • 200 Points 100 badge 2x thumb
I think its a glitch and here is why.   The app I was working on is a mirror copy of our primary app.  I use it as a testing ground to develop and test new QuickBase features that we may want to include in our primary app (this way I can't screw anything up in our primary app as they are not connected in any way, and I am the only user).   Just now, in the Timesheets table of the Primary app, I made a new report and gave it a unique title.  I then switched over to the Test app, went to the form properties of its Timesheets table, and in the drop down for the report link field, the new unique report from the Primary app was showing.  How did that happen?!!!  And like before, the two reports I made yesterday in the Test app were still not showing.  Further, I then clicked save on the form in the Test app and I was redirected to the TimeSheets form of the Primary app.  In all my time using the Test app, I have never run into any crossover like this, so it has to be a glitch.  I may delete my Test app and make a new copy to start fresh.