Why isn't the first field on my form active when I create a new Record?

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered

The first field on my Appointment form is a drop-down menu called Type of Appointment.  When I click New Appointment, I want this field automatically selected so that I can start typing or press the down arrow key to change the field (without clicking on it with the mouse).

We have 19 Tables, and this is the only one that behaves like this.  When I create a new Record for any of the other Tables, the first field is selected/highlighted regardless if it's a drop-down menu or text field.  I've compared the Type of Appointment field properties to drop-downs on other Tables that work properly and I can't find any difference. 

This issue happens with any drop-down menu that is moved to the top of the Appointments form.  But if I move a text field to the top and create a new Appointment, that text field IS automatically selected.

Any idea why this field is acting different than drop-downs that are at the top of my other Tables?

Photo of Derek

Derek

  • 0 Points

Posted 3 years ago

  • 0
  • 1
Photo of QuickBasePros_IDS

QuickBasePros_IDS, Champion

  • 4,208 Points 4k badge 2x thumb
I think you should report this to QuickBase. 

What I found was a multiple-choice text field had to sit underneath another data-entry type of field (I tried File Attachment and a regular text-entry field).  My data-entry field had to be hidden AND be read-only if it was a text field; or it could be visible if it was a File Attachment field.  In both these cases, my multiple choice field would then auto-select itself at the top of the form.  The first field cannot be a multiple-choice option field - it has to be a data-entry field.

My workaround for this would be as follows:

1.  Create a text field and label it [Hidden Form Element]

2.  Put the [Hidden Form Element] field at the top of your Form above the multiple-choice entry field you want to be the "1st" auto-selected field

3.  Make the [Hidden Element] field "Read Only" using the radio button on the Form Element control (** it must be made read-only for this to work**)

4.  Write a form rule that always hides the [Hidden Element] field as follows:



When Multiple Conditions are true



  When the User is in the Role Administrator

  When the User is not in the Role Administrator











Show [Hidden Element]

(Collapse hidden fields)



5. Make your Form Rule collapse hidden fields so that there's not an extra space at the top of your Form
6. Display your Form
Other "elements" above the first field do not have this effect (ie text form elements, section headings etc.); and this only needs to be done with a multiple-choice text or numeric field.  Data-entry fields do not have this problem, it seems.  
Note- with a multi-text select field this workaround does NOT work.























Photo of Derek

Derek

  • 0 Points
Thanks, I used a hidden text entry field and it did the trick!

The strangest thing about this is that I have at least 4 other Tables where the form starts with a multiple-choice text field, and none of them have this issue.  And I can't find any difference between those fields that work and this one.
Photo of QuickBasePros_IDS

QuickBasePros_IDS, Champion

  • 4,208 Points 4k badge 2x thumb
The release notes issued today appear to have identified this as a bug that will be fixed!

"Depending on the field type of the first element on a form, the form’s focus was applied inconsistently. This issue has been resolved."


http://quickbase.intuit.com/quickbase-blog/june-12-release-notes