Zapier Field Visibility

  • 1
  • 1
  • Question
  • Updated 2 years ago
  • Answered
Not all of my fields are visible when attempting to update a row via Zapier.  I click Refresh Fields but nothing happens.  I have many fields 291 so if it's only going to show a certain number of those then how can I control which ones show up in Zapier Edit Template?  Thanks-
Photo of Jared

Jared

  • 82 Points 75 badge 2x thumb

Posted 2 years ago

  • 1
  • 1
Photo of Harrison

Harrison

  • 462 Points 250 badge 2x thumb
Unfortunately, the production Zapier Quick Base connector only supports "default" fields on the table It is an impactful limitation. If you can make the field a default, this will work.

One other option is to simply construct API_EditRecord in Webhooks by Zapier. The only caveat here is that your usertoken will be available inside of the Zap editor and Task History. So anyone with that access can see it. If you feel that this is too much of a security risk, the only other option is to conditionally allow everyone on the internet access dynamically to the record in question. This of course introduces security risks but could be mitigated and is kind of 'security by obscurity' for the public records. For example, say you had a button which cause a webhook to Zapier to fire some process and ultimately write back data to Quick Base. If the button fills in field 1 with the current date/time and your "final" data is written to field 2, you could have a formula checkbox that says something like

If([Field 1]<>"" AND [Field 2]="",true,false)
(technically you don't need the strikethrough part but sometimes helps to include it for understanding).

Then make that field a conditional permission on the view settings of the table security. So in reality, the record is only public for a very short period of time. It is possible that Zapier chokes in the middle, or perhaps connections reflected in middle steps of your Zap fail so Zapier continues to retry them (if auto-replay is on) and in that case, the record is open during the entire time.
Photo of Jared

Jared

  • 82 Points 75 badge 2x thumb
This did the trick!  I had to select "Add this field to all new reports" in the field properties to make it a default field as you described.

Thank you!!