Skip to main content
Question

Pipeline error - Duplicate Key - does not exist

  • April 17, 2023
  • 0 replies
  • 99 views

Forum|alt.badge.img+5

I am getting errors on a few pipelines saying it can't add to the table due to duplicate key values; however, these values do not exist in the table. QB support is basically saying this is what sometimes happens in a DB with no solutions.

Today I completely deleted the entire table and ran the pipelines again - the same errors.




------------------------------
Steve Laurel
------------------------------
This topic has been closed for replies.

MarkShnierYou
Forum|alt.badge.img+22
  • Quickbase Alumni
  • April 17, 2023

The upsert may not contain duplicate keys within the upsert set.  So yes, those values do not already exists, but that is irrelevant for an upsert.  The issue is that the set of record you are trying to upsert has duplicates.

if that is unavoidable, then change your upsert process to just upsert one record at a time.  Like:

Prepare a bulk upsert
add upsert row
Commit upsert.



------------------------------
Mark Shnier (Your Quickbase Coach)
mark.shnier@gmail.com
------------------------------