Blog Post

The Qrew Blog
2 MIN READ

SOLUTION: Rich Text Formula field not showing in Grid Edit

MeredithMoore4's avatar
MeredithMoore4
Qrew Cadet
5 years ago

Are you having an issue with having your embedded report not showing your beautiful icons and formula fields when you have them set on Grid Edit?

Well I sure did, and I wanted to save you all from my hour-long rabbit hole of trying to fix it.

The problem:

I had two embedded child reports on one form both set to grid edit mode, but only one was showing all the pretty icons and rich text formulas.


Milestones embedded table showing icons in Grid Edit

Tasks embedded table NOT showing icons in Grid Edit vs. What it should be showing
So, I checked every field, link, permission, sub-children, grandparents, DNA, horoscope, formula, and view that I could find. I lined everything up so that it was exactly the same permission-wise, and still no dice. But then I thought of one more thing...
The #*%?$@^! Form / Report Permissions...
That's right kids. IF your table has more than one form you need to look at the permissions of your reports in that table. Most often they will just grab the permissions from your roles, but that can mess with your Grid Edit. And remember, this ONLY happens if you have more than one Form on your table. So yeah, that is fun.
Milestones (1 Form)
Tasks (2 Forms)

The Fix
So here is the fix. Just scroll down to the "Override role settings by report" section (right below your list of Forms) and find your embedded Report. Change the Grid Edit (Full Site) to "<Standard Behavior>". Yeah that is #*@^%*! it!
The Culprit
The Fix

I hope this has been helpful. If so, say hi to me at Empower, or just send a sugar-free energy drink over to my table. I will nod, and we will both know of the rabbit trail you didn't have to follow today.
​​

------------------------------
Meredith Moore
aka Quick Base Girl
------------------------------
Published 5 years ago
Version 1.0
No CommentsBe the first to comment