Discussions

Expand all | Collapse all

Dynamic Form rule not working in view mode

  • 1.  Dynamic Form rule not working in view mode

    Posted 12-17-2019 16:37
    I am using a basic form rule (If checkbox = checked, then hide field).  The field I am hiding is a related field (not sure if that has any impact on my question).

    When I am in edit mode, it hides the field as expected. In view mode, it becomes visible. I can't figure out what I am missing.

    ------------------------------
    Mike Tamoush
    ------------------------------


  • 2.  RE: Dynamic Form rule not working in view mode

    Posted 12-17-2019 17:46
    Do you by any chance have multiple forms on this table and have a form for edit and a form for view?

    I have found the most success by using checkboxes to show fields rather than hide them. You set the exact conditions for when it should be shown on the form and then it is automatically hidden in every other scenario. I find that easier as I only have to think about the one condition rather than a bunch of cases where it should be hidden.



  • 3.  RE: Dynamic Form rule not working in view mode

    Posted 12-17-2019 18:17
    No,

    Only 2 forms one for mobile and one main form. I have a lot of other dynamic rules that all function properly. I am thinking it has something to do with it being a related field. Maybe related fields are always visible in view mode?


    ------------------------------
    Mike Tamoush
    ------------------------------



  • 4.  RE: Dynamic Form rule not working in view mode

    Posted 12-17-2019 17:59
    You probably are using a Proxy field in your drop down.  You should set the form rule to hide the proxy field.  ie there is a table of customers and the Proxy for Related Customer is set to Customer name.

    ------------------------------
    Mark Shnier (YQC)
    Quick Base Solution Provider
    Your Quick Base Coach
    http://QuickBaseCoach.com
    mark.shnier@gmail.com
    ------------------------------



  • 5.  RE: Dynamic Form rule not working in view mode

    Posted 12-17-2019 18:44
    Winner WInner. Accidentally hid the related field and not the proxy. But strange that it hides the proxy in edit mode?

    ------------------------------
    Mike Tamoush
    ------------------------------



  • 6.  RE: Dynamic Form rule not working in view mode

    Posted 12-17-2019 18:52
    The whole point of a proxy field is that on form when in view mode, the field used is the proxy field, but in Edit mode the field behaves as the [Related XYZ] field.  
    Try this

    When in view mode right click on the field and you will see the proxy as the field properties.  then edit the record and right click and you will see that while the field is labeled like [Customer Name] the field actually on the form in edit mode is [Related Customer].

    So in edit mode the proxy is never there.

    ------------------------------
    Mark Shnier (YQC)
    Quick Base Solution Provider
    Your Quick Base Coach
    http://QuickBaseCoach.com
    mark.shnier@gmail.com
    ------------------------------