Discussions

Expand all | Collapse all

Snapshot error on first record

  • 1.  Snapshot error on first record

    Posted 9 days ago

    Hi,

    I am trying to make a field that automatically counts up (similar to record ID, but where it starts new for each project). I am using the snapshot function to accomplish this. It works fine, except for on the first iteration.

    I have 2 tables, Projects and Request for Information (RFI). Projects is the parent to RFI.

    I have a summary field that is the maximum RFI Number.
    I have a lookup field in the RFI table, of that summary field.
    In the RFI table I have a snapshot field, that snapshots the lookup field mentioned above.
    And finally on the RFI table I have a formula numeric field (RFI number) which is Snapshot Field +1

    When I add a new RFI, it shows everything correct. Snapshot = 0, RFI number =1. As soon as I save, it adjusts and becomes snapshot =1, RFI number = 2.

    After that it works perfectly. How can I get the first RFI to number correctly?

    Thank you




    ------------------------------
    Mike Tamoush
    ------------------------------


  • 2.  RE: Snapshot error on first record

    Posted 7 days ago
    Mike,

    I've played with a similar setup in the past, and as far as I remember it worked correctly. If you'd like a resource to follow, I've found this article useful. If not, please let me know and I'd be happy to look at this with you.

    Eric

    ------------------------------
    Eric Mohlman
    ------------------------------