Discussions

Expand all | Collapse all

Error in webhook while doing an action

  • 1.  Error in webhook while doing an action

    Posted 05-21-2018 22:24
    Hi ,

    I was trying to create a webhook to make an action, i.e replication of records when created in one application to another.

    <?xml version="1.0" ?>
    <qdbapi>
    <action>API_EditRecord</action>
    <errcode>30</errcode>
    <errtext>No such record</errtext>
    <errdetail>Missing &quot;rid&quot; parameter.</errdetail>
    <udata>mydata</udata>
    </qdbapi>


  • 2.  RE: Error in webhook while doing an action

    Posted 05-21-2018 22:49
    Is there a reason that you are not using an Action?
    Can you post your current Webhook Code?


  • 3.  RE: Error in webhook while doing an action

    Posted 05-22-2018 03:45
    Hi,

    <qdbapi>
    <udata>mydata</udata>
    <usertoken>%user.token.xxxxx_zmp_dqvp.Demo 2%</usertoken>

    <apptoken>xxxngn7xxxxxxxxxxxxxxxxxxx</apptoken>

    <rid>[corporate id]</rid>

    <field fid="00">[FIELD NAME]</field>
    <field fid="00">[FIELD NAME]</field>
    <field fid="00">[FIELD NAME]</field>
    <field fid="00">[FIELD NAME]</field>
    <field fid="00">[FIELD NAME]</field>
    <field fid="34">[FIELD NAME]</field>
    <field fid="13">[FIELD NAME]</field>
    <field fid="7">[FIELD NAME]</field>
    <field fid="8">[FIELD NAME]</field>
    <field fid="10">[FIELD NAME]</field>
    <field fid="11">[FIELD NAME]</field>
    <field fid="32">[FIELD NAME]</field>
    <field fid="35">[FIELD NAME]</field>


    </qdbid>


  • 4.  RE: Error in webhook while doing an action

    Silver
    Contributor
    Posted 05-24-2018 12:04
    Is your [corporate id] field id#3?  the rid (Record ID#) should still be the [Record ID#] field value even if you have renamed it.  Or if you are using a custom Key Field, use the <key></key> parameter instead.