Discussions

 View Only
  • 1.  Conditional Dropdown Working from Grid Edit, but Not working from Form

    Posted 21 days ago

    Hello All,

    I have a conditional dropdown that is working when editing a record from a report via grid edit, as well as when editing a record from the form where the value is already filled in.

    However it does not work when adding a new record or editing a record that does Not have a value already filled in. The Conditional value is on the form, yet the dropdown asks to fill in the conditional value first (which it already is)

    Anyone have a logical explanation/understanding of what's going on here? 



    ------------------------------
    Dan Park
    ------------------------------


  • 2.  RE: Conditional Dropdown Working from Grid Edit, but Not working from Form

    Posted 20 days ago
    Edited by Mike Tamoush 20 days ago

    Is the conditional value a related field or proxy field? If my memory serves, you need to be sure to have the correct one. Also, I believe if a dynamic form rule hides the field, the conditional dropdown will not work. Ironically, if the field is in a section that is hidden, it still works (I think that is the behavior, I haven't tested in a while).

    Actually, was just thinking about it more, and I think maybe the issue wasn't with dynamic form rules. I believe I had a field that only showed in view mode, so that caused it not to work. So be sure your conditional field is shown in edit/add mode.

    ------------------------------
    Mike Tamoush
    ------------------------------