Forum Discussion

MattMakris's avatar
Qrew Cadet
11 months ago

How to allow my users to sign into my real with our Google Workspace accounts (SAML)

I've been trying to set up SAML with our Google Workspace accounts. I'm entering the information from Google Workspace > Security > Authentication > SSO with SAML Applications into Quickbase > Admin Console > SAML Authentication and am getting the following error when I attempt a login with my Google account:

Error: app_not_configured_for_user

Service is not configured for this user.

Does anyone have good step-by-step instructions on how to set up SAML so that my Quickbase realm users can log in with our Google Workspace accounts? Thanks in advance!

Matt Makris

2 Replies

  • I can't specifically help, but when we set up SAML I ended up working with my account exec to put me in touch with one of their SAML experts. Then I got my IT team on a zoom call with a QB SAML expert and they all were able to work through the bugs and challenges we were having. You can try reaching out to Customer Support or your account exec to try and get some one on one help.

    Mike Tamoush
  • Hi Matt:

    It's a bit tricky. You need to enable the SAML definition for the group or OU in google via the google admin console where and for whom you want to use it. 

    Once that was configured I was still getting errors. It has something to do with the Return URL that is configured on the QB side. 

    It is BEST to make an appt with QB support once you get it properly setup on the Google side.  I was getting pretty frustrated too  -- but working with the support engineer at Quick Base we were able to get it figured out just fine.  

    There was some thing that had to do with one of the URL constructs in the QB definition side. 

    It's now working just fine and been working without a flaw for months and months. 


    joe vandervest