Forum Discussion

LordsmanBurgos's avatar
LordsmanBurgos
Qrew Trainee
12 months ago

Pipeline Validation Error

Hej everyone!

I'm trying to set up a pipeline that captures a value at 5pm.The one with the value is set to a Numeric Fomula:

ToNumber(SumValues(GetRecords("{1211.TV.'"&[Adviser_7]&"'}AND{2723.LTE.1}AND{2716.EX.1}","_MyApp_ID_"), 2731))

The other field is an everyday blank Numeric field.
I can write numbers between each other, but as soon as I try to write the value from the formula above to the latter, I get this error:

Validation error: Incorrect template "{{a.total_adviser7}}". ValueError: invalid literal for int() with base 10: 'total_adviser7' 

I've tried these expressions:

{{a.total_adviser7 | int }}

{{a.total_adviser7 | float }}

{% set stringNumber = a.total_adviser7 %}
{% set integerNumber = stringNumber | int %}
{{ integerNumber }}

But alas, none of them worked.
Any kind of guidance with this, would be immensely aprecciated.

Cheers,



------------------------------
Lordsman Burgos
------------------------------

1 Reply

  • DougHenning1's avatar
    DougHenning1
    Community Manager

    Is step A a search step?  If so, then you need a loop to process the results.  Or if you only want the first record then you can reference it specifically like this:

    {{a[0].total_adviser7 | int }}


    ------------------------------
    Doug Henning
    ------------------------------