Forum Discussion

TonyGonzalez's avatar
TonyGonzalez
Qrew Trainee
4 months ago

View Only Permissions

Moving into a new phase of our QB rollout.  I have a report I want to make available as read only.  I ahve done what I thought I needed to, but upon testing as a viewer, the "edit" icon is still available and when it is clicked on it takes the test user to an editable page.  What am I missing?  The report is below and some other applicable screenshots.



------------------------------
Gonzo - A Newbie, but learning fast. (Former SmartSheet evangelist who is quickly converting to QuickBase)
IT Director City of New Braunfels
------------------------------

3 Replies

  • KatlynAllen's avatar
    KatlynAllen
    Qrew Assistant Captain

    If you don't want anyone to edit from that report, you can go into the report settings and uncheck "Allow editing records from this report" , otherwise you'll have to edit the role permissions.



    ------------------------------
    Katlyn Allen
    kallen@eatatjacks.com
    ------------------------------

    • TonyGonzalez's avatar
      TonyGonzalez
      Qrew Trainee

      Thanks, everyone.  I did a combination of several of the replies.  I did find a deeper role based option, but the one I really wanted was what Katlyn offered.  Unchecking that box is going to be pretty dang standard for us on view-only reports.  It seems to be the easiest and quickest.



      ------------------------------
      Gonzo - A Newbie, but learning fast. (Former SmartSheet evangelist who is quickly converting to QuickBase)
      IT Director City of New Braunfels
      ------------------------------
  • Are you trying to make just this report read only? If the 'role' is viewer then you should be removing all modify access for this table from that role so they cannot edit any records through their security role and the report will display accordingly. 



    ------------------------------
    Chayce Duncan
    ------------------------------