Discussions

 View Only
  • 1.  Deleting Attachments

    Posted 21 days ago

    We recently switched to the new form and users are having issues deleting attachments. No form rules have been changed from the old form or permissions. We have found that the only way they can delete attachments is if we give them edit field property permissions. Does anyone know why this is? The only thing has changed is moving from the old form to the new form. 



    ------------------------------
    Codi Smith
    ------------------------------


  • 2.  RE: Deleting Attachments

    Posted 21 days ago

    I just did a test using Test as Role in a Participant role and I still got the red trashcan to delete an attachment.   So you might need to put in a support ticket to see if there's something very unique about your set up.



    ------------------------------
    Mark Shnier (Your Quickbase Coach)
    mark.shnier@gmail.com
    ------------------------------



  • 3.  RE: Deleting Attachments

    Posted 21 days ago

    Okay, the user can select the trash can put when they save the form they have an error that says unable to delete attachment. 



    ------------------------------
    Codi Smith
    ------------------------------



  • 4.  RE: Deleting Attachments

    Posted 21 days ago
    Edited by Mark Shnier (Your Quickbase Coach) 21 days ago

    Wow, you are totally right!  I went all the way through the process in the Participant role and got a lovely red pop-up saying "Failed to delete attachment".  That is a bug for sure so I suggest you put in a bug report.  I would think they would fix that on a pretty urgent basis and there is a good chance they will come back and say they know about the bug.   



    ------------------------------
    Mark Shnier (Your Quickbase Coach)
    mark.shnier@gmail.com
    ------------------------------



  • 5.  RE: Deleting Attachments

    Posted 21 days ago

    Ah! Thank you! I will put that in. 



    ------------------------------
    Codi Smith
    ------------------------------



  • 6.  RE: Deleting Attachments

    Posted 21 days ago

    Unrelated to the question but I've also come across issues on the new forms where the user deletes the file but something about it isn't 100% so formulas and other workflow related items still think the file is there and in some cases users are not required to reattach. If you need a short workaround while this bug is sorted out - you could look at a checkbox to 'delete file' that the user can check and have a webhook do an editRecord call to fully delete the file. Thats the only way I've gotten around the glitchiness with the new forms to date. 



    ------------------------------
    Chayce Duncan
    ------------------------------