Quickbase Discussions

 View Only
  • 1.  timeline temporary report not filtering correctly

    Posted 14 days ago
    Currently I am setting a time line report for a project to create a Gantt chart.
    How I have it setup is a projects will have multiple PO's to different vendors.  On each PO I can create multiple Gantt entries.  From the project I hit my formula url button to make a temporary report of all Gantt entries.

    URLRoot() & "db/" & "table ID" & "?a=q" & "&qid=5" & "&query=" &
    "{'15'.EX.'"& ToText([Project Number]) & "'}"

    When I change "&qid=5" to 1 to use the list all report the filter I have in my formula works correctly.  But when it is set to "5" which is a time line report, the filtering does not work.

    ------------------------------
    Russell Beaubien
    ------------------------------


  • 2.  RE: timeline temporary report not filtering correctly

    Posted 14 days ago
    I'm not sure the exact issue, but the way I test and set mine up is by creating the report I want (say list all, just make a copy of it), and then adding my filters as 'ask the user'. I run the report and select a dummy entry for ask the user, and then that gives me my URL that I can now edit for my purposes.

    So, perhaps make an ask the user filter that mimics what you want on your list all report, run it, and see if it gives you the syntax you need.

    ------------------------------
    Mike Tamoush
    ------------------------------



  • 3.  RE: timeline temporary report not filtering correctly

    Posted 11 days ago
    The users are looking at the relevant project I want the button to give them the right information. I could set it to be the way your saying but then the users would have to go to another table and filter it down, instead of pushing one button

    ------------------------------
    Russell Beaubien
    ------------------------------



  • 4.  RE: timeline temporary report not filtering correctly

    Posted 11 days ago
    @Russell Beaubien
    no.. you are not understanding the alternative suggestion.​

    Make a report which has an <ask the user> on Project Number. Run the report, and answer the question and observe and mimic the URL

    URLRoot() & "db/" & [_DBID_my table] & "?a=q&qid=6&nv=1&v0=" & URLEncode([Project Number])

    So the user will click the button, it will run the report and answer its own <ask the user> question.



    ------------------------------
    Mark Shnier (YQC)
    mark.shnier@gmail.com
    ------------------------------



  • 5.  RE: timeline temporary report not filtering correctly

    Posted 11 days ago
    Thanks, that worked perfectly.

    Mike and I started Messaging and I figured out the I was not getting it at first

    ------------------------------
    Russell Beaubien
    ------------------------------