Forum Discussion

RaineyJohnston's avatar
RaineyJohnston
Qrew Trainee
3 months ago

Grid-edit behavior

Is anyone experiencing new behavior with the grid-edit option? This is happening in regular table reports AND specifically grid-edit reports. When clicking the grid edit option at the top corner the page reloads with an absurd amount of fields. This new view is not a default report - or any report that exists as far as I can find. At first my fix was to make reports grid-edit from the start but now even those are showing the same behavior.

The correct columns show in preview and then reload with a huge number of columns when displaying for any record entry. I know that this is not the expected behavior - many users are reporting that they can no longer grid edit as they were able to last week. My support ticket was closed because this is "expected behavior" and I was told that I should submit a feature request if I wanted to be able to customize my grid edit columns. I know that I've done this before many times so I'm feeling lost. Is this a glitch only in my app? I have a few tables that are functioning as normal but multiple tables are exhibiting this behavior. 



------------------------------
Rainey Johnston
------------------------------

5 Replies

  • Hi Rainey,

    Yes, this is a Quickbase feature that must be understood because it is not intuitive and complex to get right. Here is how to solve the problem.

    Go to settings, forms. 

    Look below the forms there are two chevrons on the left that look like this:

    Expand these and note if anything has been changed.

    In the bottom one "override role settings by report" look for the report you are experiencing the strange behavior. On the Grid Edit (Full Site) column change the value to "Use role settings". Test and it should be back to expected behavior.

    I think by default Quickbase has these set to Use Standard Behavior. When we change the "Set how different roles use these forms", it changes every report to use the same setting. 



    ------------------------------
    Jim Harrison
    transparency = knowledge + understanding : The Scrum Dudes
    ------------------------------
    • RaineyJohnston's avatar
      RaineyJohnston
      Qrew Trainee

      Hey Jim. Thanks so much. This does seem to be the root of the issue - however in order to re-enable grid edit I had to choose <Standard Behavior> for the grid edit option. All my reports were still showing "use role settings" so I thought I would test the other options. Thanks for your help!



      ------------------------------
      Rainey Johnston
      ------------------------------
  • Not a glitch in your app - it happens to me all the time I've just learned to live with it since it's not that common for me. I've found it happens with tables that have a lot of fields or variability in the default report versus the table home page, but never dug into it to find the exact pattern. This doesn't solve your issue in any capacity but if you have a report that you want to grid edit exactly as it appears you can just add &dlta=mog to the end of any report page and it'll open it in Grid Edit. Again - not a fix, just a workaround. 



    ------------------------------
    Chayce Duncan
    ------------------------------
    • RaineyJohnston's avatar
      RaineyJohnston
      Qrew Trainee

      Hey Chayce. I really appreciate your reply. Unfortunately I still see the behavior when adding &dlta=mog to the end of the URL! So frustrating.



      ------------------------------
      Rainey Johnston
      ------------------------------
      • ChayceDuncan's avatar
        ChayceDuncan
        Qrew Captain

        Are you trying it from a report or the table home page? The dlta=mog only works if you're on an existing report off the table home page. Still - even if you get it to work it's only a workaround, best to submit the ticket to QB. 



        ------------------------------
        Chayce Duncan
        ------------------------------