Discussions

 View Only
  • 1.  Button Link not going to specific report (Going to report home)

    Posted 12-15-2021 19:33
    So I'm building this rich text dashboard and am having trouble with linking an html button with the proper report. A piece of text with the Quickbase link that is in the interface works fine, but with my own button, it just routes to the report default page rather than the specific report I want.

    ------------------------------
    Davis Ward
    ------------------------------


  • 2.  RE: Button Link not going to specific report (Going to report home)

    Posted 12-15-2021 19:49
    Can you post the code for your current button which is not working?

    ------------------------------
    Mark Shnier (YQC)
    mark.shnier@gmail.com
    ------------------------------



  • 3.  RE: Button Link not going to specific report (Going to report home)

    Posted 12-15-2021 19:50
    </font></i><font color="#ffffff" size="5"><u><i><a href="/db/brw9uatak?a=q&amp;qid=5">Pending AP Invoices</a></i></u></font>
    </p>
    <p><i><font color="#ffffff" size="5"><a href="brw9uatak?a=td"><u><font color="#ffffff" size="5"><i></i></font></u> <style> .button { border: thin; color: white; padding: 16px 24px; text-align: center; text-decoration: none; display: inline-block; font-size: 18px; margin: 2px 2px; transition-duration: 0.4s; cursor: pointer; } .button1 { background-color: ; color: white; border: 2px solid white ; } .button1:hover { background-color: #601818 ; color: white; } </style> <button class="button button1" onclick="window.location.href='brw9uatak?a=td';">Pending</button> </a> </font></i>
    </p>
    <p><i><font color="#ffffff" size="5"><a href="brw9uatak?a=td"><u><font color="#ffffff" size="5"><i></i></font></u> <style> .button { border: thin; color: white; padding: 16px 24px; text-align: center; text-decoration: none; display: inline-block; font-size: 18px; margin: 2px 2px; transition-duration: 0.4s; cursor: pointer; } .button1 { background-color: ; color: white; border: 2px solid white ; } .button1:hover { background-color: #601818 ; color: white; } </style> <button class="button button1" onclick="'brw9uatak?a=q&amp;qid=10'">Ready to Process</button> </a> </font></i>

    ------------------------------
    Davis Ward
    ------------------------------



  • 4.  RE: Button Link not going to specific report (Going to report home)

    Posted 12-15-2021 19:51
    The top section is the text that is working, the bottom two sections are the buttons that aren't working properly.

    ------------------------------
    Davis Ward
    ------------------------------



  • 5.  RE: Button Link not going to specific report (Going to report home)

    Posted 12-15-2021 19:57
    A quick guess is that the 2 buttons are missing the /db/ that the first button has

    </font></i><font color="#ffffff" size="5"><u><i><a href="/db/brw9uatak?a=q&amp;qid=5">Pending AP Invoices</a></i></u></font>
    </p>
    <p><i><font color="#ffffff" size="5"><a href="/db/brw9uatak?a=td"><u><font color="#ffffff" size="5"><i></i></font></u> <style> .button { border: thin; color: white; padding: 16px 24px; text-align: center; text-decoration: none; display: inline-block; font-size: 18px; margin: 2px 2px; transition-duration: 0.4s; cursor: pointer; } .button1 { background-color: ; color: white; border: 2px solid white ; } .button1:hover { background-color: #601818 ; color: white; } </style> <button class="button button1" onclick="window.location.href='brw9uatak?a=td';">Pending</button> </a> </font></i>
    </p>
    <p><i><font color="#ffffff" size="5"><a href="/db/brw9uatak?a=td"><u><font color="#ffffff" size="5"><i></i></font></u> <style> .button { border: thin; color: white; padding: 16px 24px; text-align: center; text-decoration: none; display: inline-block; font-size: 18px; margin: 2px 2px; transition-duration: 0.4s; cursor: pointer; } .button1 { background-color: ; color: white; border: 2px solid white ; } .button1:hover { background-color: #601818 ; color: white; } </style> <button class="button button1" onclick="'brw9uatak?a=q&amp;qid=10'">Ready to Process</button> </a> </font></i>

    ------------------------------
    Mark Shnier (YQC)
    mark.shnier@gmail.com
    ------------------------------



  • 6.  RE: Button Link not going to specific report (Going to report home)

    Posted 12-15-2021 20:05
    Added that in, but still routing to the default report page


    <p><i><font color="#ffffff" size="5"><a href="brw9uatak?a=td"><u><font color="#ffffff" size="5"><i></i></font></u> <style> .button { border: thin; color: white; padding: 16px 24px; text-align: center; text-decoration: none; display: inline-block; font-size: 18px; margin: 2px 2px; transition-duration: 0.4s; cursor: pointer; } .button1 { background-color: ; color: white; border: 2px solid white ; } .button1:hover { background-color: #601818 ; color: white; } </style> <button class="button button1" onclick="window.location.href='/db/brw9uatak?a=td';">Pending</button> </a> </font></i>
    </p>
    <p><i><font color="#ffffff" size="5"><a href="brw9uatak?a=td"><u><font color="#ffffff" size="5"><i></i></font></u> <style> .button { border: thin; color: white; padding: 16px 24px; text-align: center; text-decoration: none; display: inline-block; font-size: 18px; margin: 2px 2px; transition-duration: 0.4s; cursor: pointer; } .button1 { background-color: ; color: white; border: 2px solid white ; } .button1:hover { background-color: #601818 ; color: white; } </style> <button class="button button1" onclick="'/db/brw9uatak?a=q&amp;qid=10'">Ready to Process</button> </a> </font></i>

    ------------------------------
    Davis Ward
    ------------------------------



  • 7.  RE: Button Link not going to specific report (Going to report home)

    Posted 12-15-2021 20:10
    The report link looks strange. It's usually "a=q&qid=10"

    Not sure what the &amp is about, maybe that is correct but that semicolon before qid seems strange. Double check that?

    ------------------------------
    Mike Tamoush
    ------------------------------



  • 8.  RE: Button Link not going to specific report (Going to report home)

    Posted 12-15-2021 20:13
    It is adding it back in when I hit apply changes/save

    ------------------------------
    Davis Ward
    ------------------------------



  • 9.  RE: Button Link not going to specific report (Going to report home)

    Posted 12-15-2021 20:19
    Edited by Mike Tamoush 12-15-2021 20:20
    I don't know much about rich text dashboards, but I know if I add the amp; into my report link in the web address, it takes me to a temporary report listing all my records (essentially the table home page). I feel somewhat confident it has to do with that amp;, but unfortunately I can't be of more help!

    ------------------------------
    Mike Tamoush
    ------------------------------



  • 10.  RE: Button Link not going to specific report (Going to report home)

    Posted 12-16-2021 13:24
    Solved it. I was editing the areas bolded. I should have been editing the areas underlined and bolded.

    <p><i><font color="#ffffff" size="5"><a href="brw9uatak?a=td"><u><font color="#ffffff" size="5"><i></i></font></u> <style> .button { border: thin; color: white; padding: 16px 24px; text-align: center; text-decoration: none; display: inline-block; font-size: 18px; margin: 2px 2px; transition-duration: 0.4s; cursor: pointer; } .button1 { background-color: ; color: white; border: 2px solid white ; } .button1:hover { background-color: #601818 ; color: white; } </style> <button class="button button1" onclick="window.location.href='
    /db/brw9uatak?a=td';">Pending</button> </a> </font></i>
    </p>
    <p><i><font color="#ffffff" size="5"><a href="brw9uatak?a=td"><u><font color="#ffffff" size="5"><i></i></font></u> <style> .button { border: thin; color: white; padding: 16px 24px; text-align: center; text-decoration: none; display: inline-block; font-size: 18px; margin: 2px 2px; transition-duration: 0.4s; cursor: pointer; } .button1 { background-color: ; color: white; border: 2px solid white ; } .button1:hover { background-color: #601818 ; color: white; } </style> <button class="button button1" onclick="'/db/brw9uatak?a=q&amp;qid=10'">Ready to Process</button> </a> </font></i>

    ------------------------------
    Davis Ward
    ------------------------------