Forum Discussion

JohnOgle's avatar
JohnOgle
Qrew Trainee
5 years ago

Formula URL Form ID Shows Wrong Form

Hi,

I'm using the following formula to operate a button. Pressing the button opens a specific form, form 11.

URLRoot() & "db/" & [_DBID_TABLEINQUESTION] & "?a=er&dfid=1000011&rid=" & URLEncode ([Record ID#])& "&z=" & Rurl()

Every morning I test the button. Although the URL displayed in my browser address bar shows "...dfid=1000011", I am looking at form 2, the default form. If I go to settings/forms and preview each form, the button works properly again until the next day. Please help

------------------------------
J.T. Ogle
------------------------------

4 Replies

  • try this

    URLRoot() & "db/" & [_DBID_TABLEINQUESTION] & "?a=er&dfid=11&rid=" & URLEncode ([Record ID#])& "&z=" & Rurl()

    ------------------------------
    Mark Shnier (YQC)
    Quick Base Solution Provider
    Your Quick Base Coach
    http://QuickBaseCoach.com
    mark.shnier@gmail.com
    ------------------------------
    • StephanieMilbur's avatar
      StephanieMilbur
      Qrew Member

      It worked now how do i tell it to Auto- populate a button based on which form button was pushed?



      ------------------------------
      Stephanie Milburn
      Topgolf
      Dallas TX
      ------------------------------
      • MarkShnier__You's avatar
        MarkShnier__You
        Icon for Qrew Legend rankQrew Legend

        I don't quite understand the question, but it sounds like you need two different buttons. 



        ------------------------------
        Mark Shnier (Your Quickbase Coach)
        mark.shnier@gmail.com
        ------------------------------
    • JohnOgle's avatar
      JohnOgle
      Qrew Trainee
      Thank you, I'll give it a try. Guess I'll know tomorrow if it works

      ------------------------------
      J. T. Ogle
      ------------------------------