Forum Discussion

MeaganMcOlin's avatar
MeaganMcOlin
Qrew Trainee
7 months ago

Many-To-Many Report Issues

Hello,

I am having difficulty with the details display of my many-to-many connections. I'll provide screenshots because it is hard to explain. Basically, my connector table is called "Permissions" and when I first added a permission it showed up perfectly. 


But when I went to add permissions for subsequent employees it wouldn't show up.

I figured out that, for some reason, it is because report filters are using the first employee I set a permission for.

I can delete the second part of that filter that is using Meagan, but I have to delete it every time I add a new permission AND it then messes up my original employee (me) so that it doesn't display permissions anymore. 

I hope that makes sense. lol. What have I done wrong?

Any help would be greatly appreciated! 
Thanks,



------------------------------
Meagan McOlin
------------------------------

4 Replies

  • Can you confirm that as part of your relationship between Employees and Permissions that you have a 'Report Link' field enabled? In practice - you're report doesn't need any filters if you actually open it up in the Permissions table. So for example - lets say in the Permissions table you have a report called 'Embedded for Employees'. In practice - that report shouldn't be filtered on any one employee or any data except for things like maybe 'Active' or 'Valid' if you had some control fields. 

    On your form then, and perhaps you already have it this way so if you do then maybe just confirm that your set up is like this -- when you display the report on the form you should be basing it on the report link field from your relationship. That then tells Quickbase to dynamically filter the records based on the Employee record you're viewing. You don't need to actually put any filters in the report itself, Quickbase does it temporarily for that view. The only filters that should appear on the report are those that apply globally for all employees - such as only showing 'valid' permissions as the example.

    With that - one thing you want to make sure of though - is that if you open that report into a new window - you don't ever want to save that report as it is. Quickbase makes it a little too easy sometimes in the report page - that essentially you'd be overwriting it for the report as a whole which would create a filter issue with all other employees so you want to make sure you don't save the report with those filters in tact. 



    ------------------------------
    Chayce Duncan
    ------------------------------
    • MeaganMcOlin's avatar
      MeaganMcOlin
      Qrew Trainee

      Chayce,

      Thank you for your reply. I only partially understand what you are saying though. 
      What I am doing is going into the "Employees" table, viewing an individual employee, and then seeing all the Access Groups they belong to. That is how I would like it to work. I would rather not have to go to the permissions table to see this.
      Also, I didn't ever set up any filters myself. While viewing an employee I simply clicked "New Permission" and added information from there.



      When trying to find out why that information would not show up I ended up on the page with the filters, and they were already created automatically. Now every time I add a new permission I have to go change those automatic filters and it kind of messes everything up.



      ------------------------------
      Meagan McOlin
      ------------------------------
      • ChayceDuncan's avatar
        ChayceDuncan
        Qrew Captain

        Sure - looks like everything is right, just seems that you need to update the underlying report that is being displayed. If you customize the Employee form - click down into the report itself so that the settings panel appears to the right. Should like like the following: 

        What I want to check is the very first item that has the dropdown for 'Report'. Right below that there is the hyperlink for 'Report Settings' - click that. That will bring up the underlying 'master' report that is trying to show. In that report settings page - remove ALL filters from that report. It seems like you have saved filters in the report that are conflicting with how Quickbase will natively operate embedded reports so you want to remove anything pre-stored in the report. 



        ------------------------------
        Chayce Duncan
        ------------------------------
    • MeaganMcOlin's avatar
      MeaganMcOlin
      Qrew Trainee

      Chayce,

      Disregard my last message. After rereading your response it made a little more sense to me. Seeing as you said I don't need filters at all, I clicked on "show all permission records" and bypassed all the weird auto filters altogether. Things seem to be working now! Thank you so much!



      ------------------------------
      Meagan McOlin
      ------------------------------