Discussions

 View Only
  • 1.  Link pulled into a Formlula Rich Text not working correctly

    Posted 14 days ago
    Edited by Joe Alderson 14 days ago
    Hello,

    I have a formula rich text field which is acting as the body of an automated email that's intended to be sent out to clients.

    However the link that is being pulled through isn't working, only part of the address is acting as an actual link. it's appear as this:

    https://quickbase.formengine.com/#!/render-dynamic?templateId=cc15f538-2b42-412c-9e90-5c1a7010075e&action=update&rids={"3972ef33-9766-46f8-9b17-fd26ceadf75a": "5"}&connection={"userToken": "b74e79_p8qn_0_d8f7n9dbq83rqcddux2hkb2mchwr","realm": "paystream"}

    The entirety of that is supposed to be a link to a Form Engine document clients should have to complete. You can copy and paste the entire thing into a browser, and it works, but clicking it doesn't load the page as it's only loading part of the link.

    I cannot manually edit the link itself as that's pulling directly from another field, but is there anything I can put either side of the link to force Quickbase to read the entire string of text as one link and secondly, if I can, I would like yo hyperlink it so clients just see a couple of words i.e. Personal Tax Questionniare, rather than the entire link. Is that also possible?

    How this is input into the formula rich text field itself is:

    "Hi "&[Compliance work - First Name]&",<br>\n<br>\nPlease find below a link to your "&[Compliance work - Tax Year Ending]&" Personal Tax Questionnaire.<br>\n<br>\n"&[Personal Tax Questionnaire]&"<br>\n<br>\nPlease allow a minute for the form to load."

    There is more text afterwards but it's not relevant to the issue. The link is pulling from [Personal Tax Questionnaire].

    For further context there are 4 tables involved in the way this works. These are:

    Compliance Work
    Tasks
    Emails
    Questionnaires

    The relationships between the tables are all working fine, the Form Engine link is to a form connected with the Questionnaires Table but ideally I want to be able to send it using the email templates from the Emails table.

    Thanks,

    Joe

    ------------------------------
    Joe Alderson
    ------------------------------


  • 2.  RE: Link pulled into a Formlula Rich Text not working correctly

    Posted 12 days ago
    This tested OK for me and I got your form to load.


    var text URL = "https://quickbase.formengine.com/#!/render-dynamic?templateId=cc15f538-2b42-412c-9e90-5c1a7010075e&action=update&rids={\"3972ef33-9766-46f8-9b17-fd26ceadf75a\": \"5\"}&connection={\"userToken\": \"b74e79_p8qn_0_d8f7n9dbq83rqcddux2hkb2mchwr\",\"realm\": \"paystream\"}";

    var text Hyperlink =

    "<a href=" & $URL & ">" & "Click here" & "</a>";



    "Hi " & "Mark" & ",<br>\n<br>\nPlease find below a link to your " & "Compliance" &" Personal Tax Questionnaire.<br>\n<br>\n"& "Questionaire" &"<br>\n<br>\nPlease allow a minute for the form to load.  "  &  $Hyperlink

    You will see that I added backslashes ahead if each quote in the URL so they would not be seen as normal quotes, but just part of the string.  I replaced your fields in the words with hard coded text so you will need to revert this back to your own fields.

    ------------------------------
    Mark Shnier (Your Quickbase Coach)
    mark.shnier@gmail.com
    ------------------------------



  • 3.  RE: Link pulled into a Formlula Rich Text not working correctly

    Posted 10 days ago
    Edited by Joe Alderson 10 days ago
    Hi Mark, that's great. The link works fine now in a new field [Questionnaire Link for Emails].

    The hyperlink isn't working for some reason though, it's just treating the whole formula as part of the url. I've tried creating a new Formula URL field for it too, and that's doing the same thing.

    I've tried:

    var text Hyperlink = "<a href=" & [Questionniare Link for Emails] & ">" & "Click here" & "</a>"; 

    And it's giving an "Expecting Text" error. I've tried it with entering entering the entire URL where [Questionnaire Link for Emails] is and that does the same.

    If I delete the semi-colon the error goes away but the link doesn't work.

    If I save it with the error it just shows as this:


    But the link is broken.

    What I've done is the part of the link that changes depending on the record is the Questionnaire ID Text, so in the link for emails I've typed out the URL as you have above, but inserted that field at the point where it needs to change from client to client, then continued with the url free typed beyond that point. So the link for Email is working fine now.

    I'll keep having a play around with that, the more important part is the link working.

    Thanks a lot for your help with that.

    ------------------------------
    Joe Alderson
    ------------------------------



  • 4.  RE: Link pulled into a Formlula Rich Text not working correctly

    Posted 9 days ago
    The field type should be Formula Rich Text.  It is not quite clear to me from your latest post what the problem is, but if you post a copy and paste of your current formula (not a screen shot)  and confirm that it's in a Rich Text Formula field type, then I can help you debug it.

    ------------------------------
    Mark Shnier (Your Quickbase Coach)
    mark.shnier@gmail.com
    ------------------------------



  • 5.  RE: Link pulled into a Formlula Rich Text not working correctly

    Posted 8 days ago
    Hi Mark,

    It is actually working now, I changed it to a formula rich text and then had to delete the semi-colon at the end so the formula reads:

    "<a href=" & [Questionniare Link for Emails] & ">" & "Click here" & "</a>"

    And now the hyperlink works fine.

    Thanks for your help.


    ------------------------------
    Joe Alderson
    ------------------------------