Forum Discussion

DominicRodrigue's avatar
Qrew Member
2 years ago

There was an error copying the records. Contact the application administrator with the error details below. Error Details: CopyMasterDetail does not allow looping relationships

I created a copy of an app as a "demonstration/test".  In it, I enabled a button to Copy Master & Detail Records.  It worked perfectly in the "demonstration/test" environment, but not in the live app and I'm not sure what I need to look to so that I can correct it.

From what I can tell, all relationships look to be the same.  One thing that was weird was when Choosing a Table in the Copy Master & Detail Records, one table was available in one, but not available in the other.  

I have a table called ACME (parent).  That's related to another table called ACME Registrations (child).  I want to copy an ACME and include all their registrations.  It worked in the test.  When I set it up in the test, the ACME Registrations table was not available to select.  But the button worked perfectly.

When I set it up in the live application, ACME Registrations was an option to select.  The button was still created, but when I hit it, I get the error mentioned in the subject.

Here's the button formula from the one that produces the error:
"javascript:void(copyMasterDetailButtonHandler('&copyFid=6&destrid=0&sourcerid=" & [Record ID#] & "', 'bsixb4euj'))"

Here's the button formula from the one that does not produce an error:
"javascript:void(copyMasterDetailButtonHandler('&copyFid=6&destrid=0&sourcerid=" & [Record ID#] & "', 'bsyeqwhs6'))"

Any help would be greatly appreciated.

Dominic Rodriguez

2 Replies

  • You can add relfid to your formula as below
    "javascript:void(copyMasterDetailButtonHandler('&relfids=xx,yy,zz&copyFid=6&destrid=0&sourcerid=" & [Record ID#] & "', 'bsixb4euj'))"

    and change xx, yy, zz to filed ids of report links field ids(You can find these in relationships). Try it with one of them at a time to see which relationship is causing issue.

    "javascript:void(copyMasterDetailButtonHandler('&relfids=xx&copyFid=6&destrid=0&sourcerid=" & [Record ID#] & "', 'bsixb4euj'))"

    As Mark said you can always contact Quickbase support to get help.
    I hope this helps

    Razi D.
    WEP Forms
  • It's pretty hard to debug this kind of thing on the community forum. I suggest you put in a support ticket to have a Quickbase staff member look at it with you, or if you want some paid advice to try to solve the problem you can contact me by my signature line in my email.

    Mark Shnier (Your Quickbase Coach)