Key field is not sorting correctly

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • In Progress
I have a text field, which I just changed from regular to key field. This field starts with year that task was generated and then number. If it has revisions, it will say "R" then a number.

EX : 2017-88 R1, 2016-40, 2010-108 R4

When I changed this field into a key field, it stopped sorting correctly. It wants to randomly sort even though I keep on clicking on the field to sort from Z to A.

Anyone have any idea what I can do?
Photo of Neve

Neve

  • 260 Points 250 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Matthew Neil

Matthew Neil

  • 31,478 Points 20k badge 2x thumb
I've had some odd behavior before when I try sorting things that has a hyphen (-) in it.  
Try checking some of your default reporting options.  Or how the "R" might be affecting it.

Just throwing out ideas, but it seems a little odd.  Maybe some screen shots might help us see something.  Sorry I don't have a better solution.
Photo of QuickBasePros_IDS

QuickBasePros_IDS, Champion

  • 2,266 Points 2k badge 2x thumb
It's possible that the report you are in has a first-level Sort that is overriding the sort order you are requesting.  Try creating a brand new report from scratch.  If you're still getting the sorting error when there are no other sort criteria; then submit a support ticket to QuickBase for debugging.
Photo of Sam C

Sam C

  • 222 Points 100 badge 2x thumb
I had a similar issue recently with sorting by a text field. Try:

  1. Downloading a spreadsheet of the report and see if it sorts correctly in excel, and if there are any leading spaces that might be causing problems. 
  2. Making a Formula - Text field that is simply equal to the key field, and sorting by that. 
  3. If that sorts correctly, you probably have the same bug I did. I was able to fix it by downloading a copy, and then importing it with key fields to match and update the existing records. After that it worked correctly.